You need at least PHP 5.6 to install PrestaShop. Your current PHP version is 5.4.16